phpMyAdmin gets patch for multiple vulnerabilities

Alert

phpMyAdmin gets patch for multiple vulnerabilities

SearchSecurity.in Staff

Popular MySQL administration tool phpMyAdmin has received fixes for vulnerabilities that could allow attackers to inject and execute arbitrary code. Termed as security releases by the developers, the latest versions phpMyAdmin 3.4.3.1 and 3.3.10.2

Continue Reading This Article

Enjoy this article as well as all of our content, including E-Guides, news, tips and more.

By submitting your email address, you agree to receive emails regarding relevant topic offers from TechTarget and its partners. You can withdraw your consent at any time. Contact TechTarget at 275 Grove Street, Newton, MA.

You also agree that your personal information may be transferred and processed in the United States, and that you have read and agree to the Terms of Use and the Privacy Policy.

Safe Harbor

patch critical vulnerabilities reported by security research firm Secunia.

phpMyAdmin versions prior to 3.3.10.2 and 3.4.3.1 are affected by these vulnerabilities. Secunia clarifies that branch 2.11.x of phpMyAdmin is not affected by the vulnerabilities. The developers recommend that all users using older phpMyAdmin versions immediately update to the new versions.

According to Secunia, the vulnerable phpMyAdmin functions include Swekey_login(),PMA_createTargetTables() and PMA_displayTableBody(). The firm also reported a setup script vulnerability that could allow arbitrary PHP code injection. More details about these vulnerabilities are available at the Secunia advisory.